[Soci SLIP] Problema KDE

Lidia lidia.casa a alice.it
Lun 2 Apr 2007 23:16:35 CEST


Lucio Crusca ha scritto:
> Alle 22:32, lunedý 2 aprile 2007, geeno kis ha scritto:
>   
>> Ho un problema con Knoppix: non riesco ad aprire le applicazioni
>> grafiche con kde....
>>     
> Diciamo che la tua descrizione del problema non mi Ŕ chiarissima, ovvero non 
> capisco bene in quali casi funziona e quali no, comunque provo ad intuire il 
> problema: se non ricordo male in knoppix oltre al comando "xhost +" prima 
> di "su" devi poi anche dare il comando "export DISPLAY=:0.0" dopo essere 
> diventato root con "su".
>
> Ciao,
> Lucio.
>
> _______________________________________________
> Soci mailing list
> Soci a mail.pinerolo.linux.it
> http://mail.pinerolo.linux.it/mailman/listinfo/soci
>
>   
Effettivamente Ŕ un po' difficile da spiegare, riassumendo suppongo che 
il problema stia nel fatto che non posso avviare applicazioni che 
richiedono i permessi di root dal normale men¨ o comunque interfaccia 
KDE, i quali invece richiedono il famoso comando xhost + per 
funzionare(forse), perci˛ ogni volta quando avvio determinati programmi 
mi dÓ su ha restituito un problema, con la configurazione ho risolto 
perchŔ sapendo che il comando era sudo pppoeconf: prima da user davo 
xhost +, poi da root do sudo pppoeconf e parte graficamente, solo che di 
questo so il comando ma di tutto il resto delle applicazioni il comando 
specifico non lo so quindi come un normale utente clicco sulla voce del 
programma in questione nel men¨ ma mi da quello stramaledetto errore, il 
problema maggiore Ŕ che son sempre di pi¨ le applicazioni utili che 
richiedono i privilegi root quindi se non posso averli non posso 
usarli.....Soluzioni?

PS:

export DISPLAY=:0.0 non lo do

Grazie mille
riccardo



Maggiori informazioni sulla lista Soci